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DISCLAIMER 

YCHIOT has the right to update the product description without informing the 

customer. Changes in functions and specifications will be published in product 

errata or new versions of documents as much as possible. It is recommended that 

customers login to YCHIOT official website www.ychiot.com to download the latest 

product description documents. 

 

LIFE SUPPORT POLICY 

YCHIOT products are not authorized to be used in high safety areas (such as places 

where there is danger to life), because serious personal injury or death may be 

caused if the products are operated incorrectly. If a customer uses or sells YCHIOT 

products to high security areas, the customer needs to bear all the responsibilities; 

If this product is used in the field of high security, the customer needs to agree that 

YCHIOT and its agents are completely irresponsible. 

 

Note! Electrostatic sensitive equipment. When using the product, take 

precautions to prevent permanent damage. 

 

REGULATORY CERTIFICATION 

All users who use this module for product development must obtain the approval 

of the local radio supervision and management department before marketing or 

selling the product, and the customer must assume all responsibilities for obtaining 

the approval from the relevant authorities. 
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1 Overview 

Users can update the firmware of the research and innovation UWB module in the 

following ways, please download it according to the model you selected. 

Table 1.1 A list of upgrade methods for YCHIOT dev-kit series 

 已购源码客户 未购源码的客户 

Applicable models Mini3 

Mini3s 

Mini3sPlus 

Mini4sPlus 

Mini4 

Mini5 

Protag(STM32) 

Mini3 

Mini3s 

Mini3sPlus 

Mini4sPlus 

Mini4 

Mini5 

Protag(STM32) 

Update method Download the firmware by 

using the Keil 

Download the .hex file 

upgrade program for the 

module 

Tools & Software hardware: ST-LINK Debugger 

software: Keil MDK 

hardware: ST-LINK Debugger 

software: ST-LINK Utility 

Reference Chapter 4 Chapter 2 

Table 1.2 YCHIOT commercial product series upgrade methods 

 Anchor upgrade Tag upgrades 

Applicable models ProAnc (STM32) ProCard (NRF52832) 

Protag (NRF52832). 

Update method Download the .hex file 

upgrade program for the 

module 

Download the .hex file 

upgrade program for the 

module 

Tools & Software HARDWARE: ST-LINK 

Software: ST-LINK Utility 

HARDWARE: J-LINK 

SOFTWARE: J-FLASH 

Reference Chapter 4 Chapter 3 
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2 Upgrade by ST-LINK Utility 

2.1 About STM32 ST-LINK Utility 

The main function of the STM32 ST-LINK Utility software is mass production (a tool 

for downloading codes in batches). It is also a more practical tool, when we need to 

view the chip FLASH data, we can quickly locate and find the data we want (provided 

that no protection is added). 

The STM32 ST-LINK Utility software includes the ST-Link driver. If you install STM32 

ST-LINK Utility software, your ST-Link does not need to install drivers separately, and 

can be used directly (such as Keil, IAR online debugging, downloading, etc.). 

STM32 ST-LINK Utility software can quickly read STM32 chip model, ID, version and 

other information in addition to fast reading FLASH data. 

 

Figure 2.1 STM32 ST-LINK Utility interface 

2.2 Software installation 

The STM32 ST-LINK Utility integrated development environment is relatively simple 
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to install (basically all the way down). Take the "STM32 ST-LINK Utility v3.1.0 setup.exe" 

software downloaded above as an example. 

1. Unzip the software, double-click "STM32 ST-LINK Utility v3.1.0.exe" to enter the 

process of preparing for installation (extraction).  

2. Go to the installation wizard and click "Next". 

 

3. Agree to the license and click "Yes". 

 

4. Select the installation path (default here) and click "Next". 
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5. Enter the installation process, less than a minute. 

6. At the end of the installation, prompt "Install Driver", click "Next", and finally click 

"Finish" to complete the installation. 

7. Click "Finish" to complete the installation of the host computer software and ST-

LINK driver. 

8. Check the version: Open Software - > Help - > About, you can see that the version 

is updated. 
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2.3 Upgrade steps 

 Hardware connection 

The Mini3s/Mini3sPlus hardware connection method is shown in the figure below.  
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The hardware connection method of Mini3/M ini 4/Mini5 is shown in the figure below.  
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The hardware connection method of Mini4sPlus is shown in the figure below.  
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The connection method between the wall-mounted anchor and the downloader: 

unscrew the screws on the anchor and open the cover. Connect the ST-LINK V2 

downloader to the J-TAG base of the main control board of the anchor through a flat 

cable  

 

The connection method between the anchor with waterproof cast aluminum shell and 

the downloader: open the cast aluminum shell of the anchor and connect the ST-LINK 

V2 downloader to the J-TAG base of the main control board of the anchor through 

the flat cable. Since there are many styles of J-TAG pin, please refer to the definition 

of J-TAG pin on the PCB. The SWD download mode requires VCC SWDIO SWCLK GND. 
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 Software connection 

Open the STM32 ST-LINK Utility software and connect the chip: Target-> Connect or 

click the connection shortcut button directly (as shown below). NOTE: THE PREMISE 

OF READING FLASH INFORMATION IS THAT NO READ PROTECTION IS ADDED. Before 

clicking the "Quick Connect", you can set the address, size, and data width.  

 

Quick Connect 
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 Load Hex 

After connecting the chip in the previous step and correctly identifying the chip, open 

the program (hex) file that needs to be downloaded. Open hex files can be opened 

from the menu bar (File -> Open File) or directly drag the hex file to the FLASH area.  

 

 Download Hex 

After opening the hex file in the previous step, click "Download" (Target -> Program, 

or you can directly click the QUICK DOWNLOAD shortcut button, as shown below). 

 

A pop-up confirmation window, such as hex file path, verification method, etc., 

confirm that the information is correct, click "Start" to start the download program. 

For example, I named the executable hex file "SPI.hex", which is located on the desktop.  

open hex file 

Or drag the hex file here 

QUICK DOWNLOAD 
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The length of the download process is related to the size of the program, which is 

generally fast, and the appearance of "Verification... OK", indicating that the download 

was successful. 

 

2.4 Configuration UWB parameters 

After updating the firmware, you also need to use the AT command to configure the 

rate, channel, and address of the UWB device so that the module can be used normally. 

For specific operation, please refer to the user manual AT command configuration 

method of each UWB device.  

  

DONE 

Click Start 
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3 Upgrade by J-FLASH 

3.1 J-Flash introduction 

J-Flash is a separate Flash ISP programming software released by SEGGER (J-LINK 

emulator manufacturer), which supports flashing HEX and BIN format files to the Flash 

of a single-chip microcomputer. 

J-Flash is integrated into the J-LINK driver, and when we install the J-LINK driver, we 

also install J-Flash.  

Note: Sections 3.2 and 3.3 are operated using the J-LINK V9.0 downloader 

3.2 Install J-LINK driver 

Double-click to start the installation and click NEXT 

 

Figure 3.2.1 JLINK driver installation 

Click [I Agree] to continue the installation 
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6  

图 3.2.2 JLINK 驱动安装 

Set the installation options of the J-LINK driver, recommend the default installation 

method, and click [Install] to start the installation 

 

Figure 3.2.3 JLINK driver installation 

The installation process pops up as shown in Figure 3.2. 4, click OK 

Note: The "Keil MDK-ARM" check box appears because the MDK development 

software is installed on this computer. If there is other development software in the 

computer, other check items may appear, but you can not check it. If you do not check 
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the items, you can also click [OK] directly 

 

Figure 3.2.4 JLINK driver installation 

Click [Finish] to complete the installation of the J-LINK driver 

 

Figure 3.2.5 JLINK driver installation 

3.3 Steps of upgrading by J-Flash 

Find the J-LINK installation directory, the default installation location is shown in 

Figure 3.3.1, and double-click to open the J-Flash software 
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Figure 3.3.1 Installation directory 

After the software starts, a pop-up will pop up as shown in Figure 3.3.2, you can select 

the last retained J-Flash project, or you can choose to create a new project. Here we 

select Create a new project and click [Start J-Flash].  

 

Figure 3.3.2 J-Flash 

As shown in Figure 3.3.3, click [...] 
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Figure 3.3.3 J-Flash 

Then click the drop-down arrow as shown in Figure 3.3.4 to find Nordic Semi as shown 

in Figure 3.3.5 

 

Figure 3.3.4  J-Flash 
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Figure 3.3.5 J-Flash 

After clicking Nordic Semi, select the nRF52832_xxAA chip and click [OK] as shown in 

Figure 3.3.6 

 

Figure 3.3.6 J-Flash 
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Click OK again, as shown in Figure 3.3.7 

 

Figure 3.3.7 J-Flash 

The following interface appears, as shown in Figure 3.3.8 

 

Figure 3.3.8 J-Flash 
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nRF52832 requires the download of two hex files, one (application ) 

and one (application), the entire download process is 

described below.  

Run "File->Open data file" to find the protocol stack hex file, or drag the hex file 

directly into the J-Flash software 

 

Figure 3.3. 9 J-Flash 

Plug JLINK into the download port of the target board (Note: the download line should 

not exceed 10cm, the pin of the download port should be corresponding, the target 

board must be powered on), and then execute "Target->Connect", if the connection 

is successful, the content displayed is shown in Figure 3.3.10 
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Figure 3.3.10 J-Flash 

Press the shortcut key F4 or execute "Target->Manual Programming->Erase Chip" to 

erase the chip, as shown in Figure 3.3.1 1, the chip is erased successfully, click OK 

 

Figure 3.3.11 J-Flash 



ap03-YCHIOT uwb device firmware upgrade_V1.1 

© YCHIOT 2016-2023 ALL RIGHTS RESERVED 

www.ychiot.com 

Page 22 

Press the shortcut key F7 or run "Target->Production programming" to program the 

protocol stack hex, as shown in Figure 3.3.12, the hex download is successful, click OK 

 

Figure 3.3.12 J-Flash 

Execute "File-> Open data file" to locate the application hex file, or drag the hex file 

directly into the J-Flash software, as shown in Figure 3 As shown in 3.13.  

 

Figure 3.3.13 J-Flash 

Press the shortcut key F7 or execute "Target->Production Programming" to program 
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the application hex, as shown in Figure 3.3.12, the hex download is successful, click 

OK.  

Then press the shortcut key F9 or run "Target->Manual Programming->Start 

Application" to run the programmed program.  

When closing J-Flash, it will prompt whether to save the current project, here we can 

save the project configured this time, so that the next time you use it, you can directly 

open the saved project in the welcome interface, without configuring the project 

again. 

3.4 Configuration UWB parameters 

After updating the firmware, you also need to use the AT command to configure the 

rate, channel, and address of the UWB device so that the module can be used normally. 

For specific operation, please refer to the user manual AT command configuration 

method of each UWB device.  
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4 Upgrade by Keil 

4.1 Develop software 

Two pieces of software are required, the Keil5 installation software mdk520 and 

Keygen. Please note that enterprise users are requested to purchase genuine Keil 

software, and YCHIOT will not bear any consequences if there is a legal dispute caused 

by using Keygen.  

4.2 Install KEIL 5 

Double-click to start the installation and click Next 

 

Figure 4.2.1 MDK520 installation startup screen 

Select I agree to all terms of the preceding License Agreement, click Next； 
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Figure 4.2.2 mdk520 License Agreement screen 

Select the appropriate installation path to install Keil5, if there are no special 

requirements, install it according to the default path. 

 

Figure 4.2 3 MDK520 Select the installation path 

Fill in personal information, which can be filled in at will, and do not need to fill in real 

information. 
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Figure 4.2.4 The MDK520 information filling interface 

Until completion, the desktop generates a Keil shortcut icon, and the installation 

prompt of the pack automatically pops up. 

 

Figure 4.2.5 Pack Installer 

4.3 KEIL 5 PACK INSTALLATION 

Click OK to enter the package installation interface (if it does not pop up, click 

on the menu bar).  

 

Figure 4.3.1 Keil 5 Menu Bar 

In the Pack column, all the types of single-chip microcomputers are listed, and there 
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is an Install button on the right side of each single-chip microcomputer, to develop 

which single-chip microcomputer, click the corresponding Install, and the 

corresponding package will be automatically installed. For the single-chip 

microcomputer used in the device hardware, select the corresponding model as 

shown in the following table. Taking STM32F103T8U6 as an example, the project 

packages that must be downloaded are: 

ARM::CMSIS 

Wedge::ARM_Complier 

Keil::MDK-Middleware 

Wedge::STM32F1xx_DFP 

Table 4.3.1 List of core microcontrollers of different UWB devices 

MODEL MAIN CONTROL SINGLE-CHIP MICROCOMPUTER 

Mini3 

Mini3s 

Mini3sPlus 

Mini4sPread 

Mini4 

Mini5 

STM32F103T8U6 

STM32F103T8U6 

STM32F103T8U6 

STM32F103T8U6 

STM32F103RCT6 

STM32G070RBT6 

ProAnc (STM32).  

ProCard (NRF52832) 

Protag (NRF52832). 

Protag (STM32). 

STM32F103RCT6 

NRF52832 

NRF52832 

STM32F103T8U6 
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Figure 4.3 2 Firmware library installation selection 

If users cannot update Pack Device normally, you can choose manual installation, find 

the single-chip microcomputer model to be developed, the summary bar will appear 

blue words, click will automatically link to the download page. Click the Download 

button to download, double-click the downloaded Keil.STM32F1xx_DFP.2 1.0, start the 

installation, the same effect as the previous automatic installation.  

 

Figure 4.3 3 Install the Device Pack manually 

4.4 Keygen cracks 

Please note that enterprise users are requested to purchase genuine Keil software, and 

the company will not bear any consequences if there is a legal dispute caused by the 

use of Keygen!!! Open Keil5 as an administrator and open License Management.  
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Figure 4.4.1 Opening License Management 

 

Figure 4.4.2 License Management interface 

Copy the CID, open the crack file, and click Generate 

to generate a Keygen 
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Figure 4.4.3 Screenshot of how to use the keygen 

Fill in Keil's LIC with the obtained Keygen, click Add LIC, and the crack is successful.  

 

4.5 Open the project 

Under the Project->MDK folder, open the project, and the interface is shown in the 

following figure.  

 

Figure 4.5 Developing the project file interface 

4.6 Compile and download 

In Target->Debug, select the downloader as ST-LINK Debugger, set the hardware 

emulation to ST-Link, and click Settings, SWD download method, speed is 4M.  
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Figure 4.6.1 Downloader settings 

 

Figure 4.6.2 Compile and download buttons 

When finished, close it, click "Build " to complete the compilation; Click "Download

" to consider the download successful.  
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